$re = '/\[\[(.*)\]\] \((.*)\)/Us';
$str = '__NOTOC__
{{SubTOC|Titel=Liste von Autoren|Index=Liste von Autoren}}
== Aa ==
: [[Bertus Aafjes]] (1914–1993), NL : [[Jeppe Aakjær]] (1866–1930), DK
: [[Johannes Aal]] (um 1500–1551), CH : [[Hans Aanrud]] (1863–1953), NO
: [[Emil Aarestrup]] (1800–1856), DK : [[Soazig Aaron]] (* 1949), FR: [[Ivar Aasen]] (1813–1896), NO
== Ab ==
: [[Petrus Abaelardus]] (1079–1142), FR : [[Sait Faik Abasıyanık]] (1906–1954), TR
: [[Lynn Abbey]] (* 1948), US : [[Jacob Abbott]] (1803–1879), US
: [[John Stevens Cabot Abbott]] (1805–1877), US : [[Abdullah bin Abdul Kadir]] (1795–1852), MAL
: [[Abe Kōbō]] (1924–1993), JP : [[Rebecca
Abe]] (*
1967), D ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);