# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\[(.*)\]\] \((.*)\)"
test_str = ("__NOTOC__\n\n"
"{{SubTOC|Titel=Liste von Autoren|Index=Liste von Autoren}}\n\n"
"== Aa ==\n"
": [[Bertus Aafjes]] (1914–1993), NL : [[Jeppe Aakjær]] (1866–1930), DK\n"
": [[Johannes Aal]] (um 1500–1551), CH : [[Hans Aanrud]] (1863–1953), NO\n"
": [[Emil Aarestrup]] (1800–1856), DK : [[Soazig Aaron]] (* 1949), FR: [[Ivar Aasen]] (1813–1896), NO\n\n"
"== Ab ==\n"
": [[Petrus Abaelardus]] (1079–1142), FR : [[Sait Faik Abasıyanık]] (1906–1954), TR\n"
": [[Lynn Abbey]] (* 1948), US : [[Jacob Abbott]] (1803–1879), US\n"
": [[John Stevens Cabot Abbott]] (1805–1877), US : [[Abdullah bin Abdul Kadir]] (1795–1852), MAL\n"
": [[Abe Kōbō]] (1924–1993), JP : [[Rebecca \n"
"Abe]] (* \n"
"1967), D ")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.