#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*(?:(?:(\w+)\|)?(?|(?:(aa|bb|cc):(?:(\w+):)?)|(?:((?2)):)?(\w+):)?)?(\w+)::(\w+)$"
Local $sString = " group4::group5" & @CRLF & _
" aa:group4::group5" & @CRLF & _
" bb:group4::group5" & @CRLF & _
" cc:group4::group5" & @CRLF & _
" group1|group4::group5" & @CRLF & _
" group1|aa:group4::group5" & @CRLF & _
"" & @CRLF & _
" group3:group4::group5" & @CRLF & _
" aa:group3:group4::group5" & @CRLF & _
" group1|group3:group4::group5" & @CRLF & _
"group1|aa:group3:group4::group5" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// aa, bb, cc must goes to group2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")