re = /^\h*(?:(?:(\w+)\|)?(?|(?:(aa|bb|cc):(?:(\w+):)?)|(?:((?2)):)?(\w+):)?)?(\w+)::(\w+)$/m
str = ' group4::group5
aa:group4::group5
bb:group4::group5
cc:group4::group5
group1|group4::group5
group1|aa:group4::group5
group3:group4::group5
aa:group3:group4::group5
group1|group3:group4::group5
group1|aa:group3:group4::group5
// aa, bb, cc must goes to group2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end