use strict;
my $str = ' group4::group5
aa:group4::group5
bb:group4::group5
cc:group4::group5
group1|group4::group5
group1|aa:group4::group5
group3:group4::group5
aa:group3:group4::group5
group1|group3:group4::group5
group1|aa:group3:group4::group5
// aa, bb, cc must goes to group2';
my $regex = qr/^\h*(?:(?:(\w+)\|)?(?|(?:(aa|bb|cc):(?:(\w+):)?)|(?:((?2)):)?(\w+):)?)?(\w+)::(\w+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}