using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Building1-Lab1-.+$";
string input = @"Building1-Lab1-DeviceABC1
Building1-Lab1-DeviceABC2
Building1-Lab1-DeviceXYZ1
Building1-Lab2-DeviceABC1
Building1-Lab2-DeviceABC2
Building1-Lab2-DeviceXYZ1
Building2-Lab1-DeviceABC1
Building2-Lab1-DeviceABC2
Building2-Lab1-DeviceXYZ1
Building2-Lab2-DeviceABC1
Building2-Lab2-DeviceABC2
Building2-Lab2-DeviceXYZ1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}