$re = '/^Building1-Lab1-.+$/m';
$str = 'Building1-Lab1-DeviceABC1
Building1-Lab1-DeviceABC2
Building1-Lab1-DeviceXYZ1
Building1-Lab2-DeviceABC1
Building1-Lab2-DeviceABC2
Building1-Lab2-DeviceXYZ1
Building2-Lab1-DeviceABC1
Building2-Lab1-DeviceABC2
Building2-Lab1-DeviceXYZ1
Building2-Lab2-DeviceABC1
Building2-Lab2-DeviceABC2
Building2-Lab2-DeviceXYZ1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);