#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\w-]+[_][\w-]*)"
Local $sString = "904-555-1212_Ramada-Holiday-opt2" & @CRLF & _
"foo ABC_TEMP_11_2011_09-02_9045551234-opt2 foo " & @CRLF & _
"foo abc_TEMP_11_2011_09-02_9045551234 foo " & @CRLF & _
"foo 904-900-2197_9045551212 foo " & @CRLF & _
"foo FooBar_AL_2055551212 foo " & @CRLF & _
"foo 904-555-1212_9045551212 foo " & @CRLF & _
"Maintenance Notification 7725551212 Phone FooBaz_at_St_Lucie_West_FL_7725551212 liveCallback" & @CRLF & _
"1@FooFoo_at_Summerwood_TX_2814581010|sg(14)" & @CRLF & _
"users/Jacksonville_FL/MG|m" & @CRLF & _
"Office Notification 5105551212 Phone Los_Angeles_CA" & @CRLF & _
"Maintenance LogIn" & @CRLF & _
"Courtesy Transfer 8665551212" & @CRLF & _
"SIP/trunk_2_abc/18669302777" & @CRLF & _
"1@Popes_Hat_NC_7045551212|sg(14)" & @CRLF & _
"users/Frogs_Feet_Washington_DC_2025551212/MG|m" & @CRLF & _
"users/Mt_Food_Portland_OR_5035551212/INTRO|m" & @CRLF & _
"SIP/trunk_2_icc/18669302777" & @CRLF & _
"3@Jelly_Bean_NC_8285551212|sg(14)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)