import re
regex = re.compile(r"([\w-]+[_][\w-]*)", flags=re.MULTILINE)
test_str = ("904-555-1212_Ramada-Holiday-opt2\n"
"foo ABC_TEMP_11_2011_09-02_9045551234-opt2 foo \n"
"foo abc_TEMP_11_2011_09-02_9045551234 foo \n"
"foo 904-900-2197_9045551212 foo \n"
"foo FooBar_AL_2055551212 foo \n"
"foo 904-555-1212_9045551212 foo \n"
"Maintenance Notification 7725551212 Phone FooBaz_at_St_Lucie_West_FL_7725551212 liveCallback\n"
"1@FooFoo_at_Summerwood_TX_2814581010|sg(14)\n"
"users/Jacksonville_FL/MG|m\n"
"Office Notification 5105551212 Phone Los_Angeles_CA\n"
"Maintenance LogIn\n"
"Courtesy Transfer 8665551212\n"
"SIP/trunk_2_abc/18669302777\n"
"1@Popes_Hat_NC_7045551212|sg(14)\n"
"users/Frogs_Feet_Washington_DC_2025551212/MG|m\n"
"users/Mt_Food_Portland_OR_5035551212/INTRO|m\n"
"SIP/trunk_2_icc/18669302777\n"
"3@Jelly_Bean_NC_8285551212|sg(14)\n\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)