# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^update\s+(?<table>[a-z_]+)\s+set\s+(?<columns>.+(?=.*\bwhere\b))(?:\s+where\s+(?<where>.+))?;?$//i;t' <<< "update nabi set fjfhj where jjj;"