import Foundation
let pattern = #"^update\s+(?<table>[a-z_]+)\s+set\s+(?<columns>.+(?=.*\bwhere\b))(?:\s+where\s+(?<where>.+))?;?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"update nabi set fjfhj where jjj;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}