$re = '/^update\s+(?<table>[a-z_]+)\s+set\s+(?<columns>.+(?=.*\bwhere\b))(?:\s+where\s+(?<where>.+))?;?$/i';
$str = 'update nabi set fjfhj where jjj;';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;