$re = '/\|\|([^\n]+?)\|\|/';
$str = 'This is some ||spoiler text|| that we want to avoid people from seeing, otherwise they may see spoilers about ||the new movie that came out yesterday||.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);