re = /\|\|([^\n]+?)\|\|/
str = 'This is some ||spoiler text|| that we want to avoid people from seeing, otherwise they may see spoilers about ||the new movie that came out yesterday||.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end