#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d(?:,-)+|-(?:,-)*,\d(?:,-)*)$"
Local $sString = "-,-,-,9,-" & @CRLF & _
"9,-,-" & @CRLF & _
"9,6,-,-" & @CRLF & _
"-,8,6,-" & @CRLF & _
"-,8" & @CRLF & _
"8,-" & @CRLF & _
"-,-,+,-" & @CRLF & _
"-,0,-,0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")