package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d(?:,-)+|-(?:,-)*,\d(?:,-)*)$`)
var str = `-,-,-,9,-
9,-,-
9,6,-,-
-,8,6,-
-,8
8,-
-,-,+,-
-,0,-,0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}