$re = '/^(?:\d(?:,-)+|-(?:,-)*,\d(?:,-)*)$/m';
$str = '-,-,-,9,-
9,-,-
9,6,-,-
-,8,6,-
-,8
8,-
-,-,+,-
-,0,-,0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);