import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "summary:.*?in\\s*(?:(?<hours>[\\d\\.]+) h)?\\s*(?:(?<minutes>[\\d\\.]+) min)?\\s*(?:(?<seconds>[\\d\\.]+) sec)?.*?average of\\s*(?<speed>[\\d\\.]+ [a-zA-Z]+\\/s)";
final String string = "summary: 0.0 KiByte in 0.3 sec - average of 0.0 B/s\n"
+ "summary: 0.0 KiByte in 12 h 24 min - average of 12.0 KiB/s\n"
+ "summary: 0.0 KiByte in 12 min - average of 12.0 MiB/s";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}