$re = '/summary:.*?in\s*(?:(?<hours>[\d\.]+) h)?\s*(?:(?<minutes>[\d\.]+) min)?\s*(?:(?<seconds>[\d\.]+) sec)?.*?average of\s*(?<speed>[\d\.]+ [a-zA-Z]+\/s)/';
$str = 'summary: 0.0 KiByte in 0.3 sec - average of 0.0 B/s
summary: 0.0 KiByte in 12 h 24 min - average of 12.0 KiB/s
summary: 0.0 KiByte in 12 min - average of 12.0 MiB/s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);