import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\*(\\w+)\\}\\}((?:.|\\n)+?)\\{\\{\\/\\w+\\}\\}";
final String string = "<table>\n"
+ " <tbody>\n"
+ " <tr>\n"
+ " <th>Trainee</th>\n"
+ " <th>Status</th>\n"
+ " <th>Invited</th>\n"
+ " <th>Score</th>\n"
+ " <th>Action</th>\n"
+ " </tr>\n"
+ " {{*Trainees}}\n"
+ " <tr>\n"
+ " <td>{{display_name}}</td>\n"
+ " <td>{{status}}</td>\n"
+ " <td>{{invited_date}}</td>\n"
+ " <td>{{percentage}}</td>\n"
+ " <td>Some action button</td>\n"
+ " </tr>\n"
+ " {{/Trainees}}\n"
+ " </tbody>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}