// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s){{\*(\w+)}}((?:.|\n)+?){{\/\w+}}").unwrap();
let string = "<table>
<tbody>
<tr>
<th>Trainee</th>
<th>Status</th>
<th>Invited</th>
<th>Score</th>
<th>Action</th>
</tr>
{{*Trainees}}
<tr>
<td>{{display_name}}</td>
<td>{{status}}</td>
<td>{{invited_date}}</td>
<td>{{percentage}}</td>
<td>Some action button</td>
</tr>
{{/Trainees}}
</tbody>
</table>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}