const regex = /(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$)).(?=.*\.)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\\G(?=[^@]*$)).(?=.*\\.)', 'g')
const str = `test01@gmail.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);