import re
regex = re.compile(r"(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$)).(?=.*\.)")
test_str = "test01@gmail.com"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)