#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^((\w{3}\d{4}(\/\d{2}-\d{2})?)|(((\w\d{6})|(\w{3}\d{4}))(\/v\d{4})?))$"
Local $sString = "X -> Digito" & @CRLF & _
"A -> Letra" & @CRLF & _
"_ -> el resto literal" & @CRLF & _
"" & @CRLF & _
"CASOS:" & @CRLF & _
"" & @CRLF & _
"1- AAAXXXX/XX-XX" & @CRLF & _
"2- AAAXXXX/VXXXX" & @CRLF & _
"3- AXXXXXX/VXXXX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")