using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\w{3}\d{4}(\/\d{2}-\d{2})?)|(((\w\d{6})|(\w{3}\d{4}))(\/v\d{4})?))$";
string input = @"X -> Digito
A -> Letra
_ -> el resto literal
CASOS:
1- AAAXXXX/XX-XX
2- AAAXXXX/VXXXX
3- AXXXXXX/VXXXX";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}