// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^((\w{3}\d{4}(\/\d{2}-\d{2})?)|(((\w\d{6})|(\w{3}\d{4}))(\/v\d{4})?))$").unwrap();
let string = "X -> Digito
A -> Letra
_ -> el resto literal
CASOS:
1- AAAXXXX/XX-XX
2- AAAXXXX/VXXXX
3- AXXXXXX/VXXXX";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}