package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@\[(.*?)\]\(contact:(\d+)\)`)
var str = `This is a string which has a @[User Full Name](contact:1) data inside.
This is a string which has a @[User Full Name](contact:1) data inside. and it can also contain many other users data like @[Second Username](contact:2) and @[Third username](contact:3) and so many others....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}