re = /@\[(.*?)\]\(contact:(\d+)\)/
str = 'This is a string which has a @[User Full Name](contact:1) data inside.
This is a string which has a @[User Full Name](contact:1) data inside. and it can also contain many other users data like @[Second Username](contact:2) and @[Third username](contact:3) and so many others....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end