const regex = /@\[(.*?)\]\(contact:(\d+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@\\[(.*?)\\]\\(contact:(\\d+)\\)', 'g')
const str = `This is a string which has a @[User Full Name](contact:1) data inside.
This is a string which has a @[User Full Name](contact:1) data inside. and it can also contain many other users data like @[Second Username](contact:2) and @[Third username](contact:3) and so many others....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}