import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-+(?:[0-9]*)-+\\n(.*)\\n((?:ERROR.*\\n)*)real\\s*(.*)\\n.*\\n.*\\n\\s*(.*)\\s\\s.*\\n?";
final String string = "-----------1------------\n"
+ "path/to/file1\n"
+ "real 0.21\n"
+ "user 0.01\n"
+ "sys 0.02\n"
+ " 11378688 maximum resident set size\n"
+ "-----------2------------\n"
+ "path/to/file2\n"
+ "real 0.21\n"
+ "user 0.01\n"
+ "sys 0.02\n"
+ " 11378688 maximum resident set size\n"
+ "-----------3------------\n"
+ "path/to/file3\n"
+ "real 0.21\n"
+ "user 0.01\n"
+ "sys 0.02\n"
+ " 11378688 maximum resident set size\n"
+ "-----------4------------\n"
+ "path/to/file4\n"
+ "ERROR: Lorem ipsum error\n"
+ "ERROR2: Lorem ipsum error 2\n"
+ "real 0.59\n"
+ "user 0.01\n"
+ "sys 0.02\n"
+ " 11378688 maximum resident set size";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}