#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|[\b\s])\d\b"
Local $sString = "12/12/2009 - No need to match" & @CRLF & _
"" & @CRLF & _
"09 - no need to match" & @CRLF & _
" '4 " & @CRLF & _
"8. match" & @CRLF & _
"7 match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")