package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[\b\s])\d\b`)
var str = `12/12/2009 - No need to match
09 - no need to match
'4
8. match
7 match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}