re = /(^|[\b\s])\d\b/
str = '12/12/2009 - No need to match
09 - no need to match
\'4
8. match
7 match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end