package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z,0-9,-]{36,36}$`)
var str = `8297a1ad-1211-43f2-bb59-f09a0314f6b4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}