import re
regex = re.compile(r"^[a-z,0-9,-]{36,36}$", flags=re.MULTILINE)
test_str = "8297a1ad-1211-43f2-bb59-f09a0314f6b4"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")