$re = '/^[a-z,0-9,-]{36,36}$/m';
$str = '8297a1ad-1211-43f2-bb59-f09a0314f6b4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);