const regex = /\s*\[\d+]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\[\\d+]', 'gm')
const str = `1 Afghanistan 6.4
2 Albania 22.9
3 Algeria 7.7
4 Angola 5.7
5 Argentina 37.2
6 Armenia 22.0
7 Australia 34.3 [2]
8 Austria 43.4`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);