import re
regex = re.compile(r"\s*\[\d+]", flags=re.MULTILINE)
test_str = ("1 Afghanistan 6.4\n"
"2 Albania 22.9\n"
"3 Algeria 7.7\n"
"4 Angola 5.7\n"
"5 Argentina 37.2\n"
"6 Armenia 22.0\n"
"7 Australia 34.3 [2]\n"
"8 Austria 43.4")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)