#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(TASK[^\n]+)(?:(?!^TASK).)+(?=FAILED!)"
Local $sString = "TASK [good task, dont need] ***********************************************" & @CRLF & _
"ok: [hostname1]" & @CRLF & _
"ok: [hostname2]" & @CRLF & _
"ok: [hostname3]" & @CRLF & _
"ok: [hostname4]" & @CRLF & _
"TASK [i need this task name] ***********************************************" & @CRLF & _
"ok: [hostname1]" & @CRLF & _
"ok: [hostname2]" & @CRLF & _
"fatal: [hostname3]: FAILED! => {some info here}" & @CRLF & _
"ok: [hostname4]" & @CRLF & _
"TASK [good task, dont need] ***********************************************" & @CRLF & _
"ok: [hostname1]" & @CRLF & _
"ok: [hostname2]" & @CRLF & _
"ok: [hostname3]" & @CRLF & _
"ok: [hostname4]" & @CRLF & _
"TASK [i need this task name] ***********************************************" & @CRLF & _
"ok: [hostname1]" & @CRLF & _
"ok: [hostname2]" & @CRLF & _
"fatal: [hostname3]: FAILED! => {some info here}" & @CRLF & _
"ok: [hostname4]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")