import re
regex = re.compile(r"^(TASK[^\n]+)(?:(?!^TASK).)+(?=FAILED!)", flags=re.MULTILINE | re.DOTALL)
test_str = ("TASK [good task, dont need] ***********************************************\n"
"ok: [hostname1]\n"
"ok: [hostname2]\n"
"ok: [hostname3]\n"
"ok: [hostname4]\n"
"TASK [i need this task name] ***********************************************\n"
"ok: [hostname1]\n"
"ok: [hostname2]\n"
"fatal: [hostname3]: FAILED! => {some info here}\n"
"ok: [hostname4]\n"
"TASK [good task, dont need] ***********************************************\n"
"ok: [hostname1]\n"
"ok: [hostname2]\n"
"ok: [hostname3]\n"
"ok: [hostname4]\n"
"TASK [i need this task name] ***********************************************\n"
"ok: [hostname1]\n"
"ok: [hostname2]\n"
"fatal: [hostname3]: FAILED! => {some info here}\n"
"ok: [hostname4]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")