using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(TASK[^\n]+)(?:(?!^TASK).)+(?=FAILED!)";
string input = @"TASK [good task, dont need] ***********************************************
ok: [hostname1]
ok: [hostname2]
ok: [hostname3]
ok: [hostname4]
TASK [i need this task name] ***********************************************
ok: [hostname1]
ok: [hostname2]
fatal: [hostname3]: FAILED! => {some info here}
ok: [hostname4]
TASK [good task, dont need] ***********************************************
ok: [hostname1]
ok: [hostname2]
ok: [hostname3]
ok: [hostname4]
TASK [i need this task name] ***********************************************
ok: [hostname1]
ok: [hostname2]
fatal: [hostname3]: FAILED! => {some info here}
ok: [hostname4]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}