#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\S*(?:facebook\.com|fb\.me)\S*$"
Local $sString = "www.facebook.com" & @CRLF & _
"www.fb.me" & @CRLF & _
"" & @CRLF & _
"www.facebook.com/pippo pallino" & @CRLF & _
"randomString"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")