$re = '/^\S*(?:facebook\.com|fb\.me)\S*$/m';
$str = 'www.facebook.com
www.fb.me
www.facebook.com/pippo pallino
randomString';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);