package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S*(?:facebook\.com|fb\.me)\S*$`)
var str = `www.facebook.com
www.fb.me
www.facebook.com/pippo pallino
randomString`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}