const regex = /^,+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^,+', 'gm')
const str = `car,model,serie
,Mercedes,324,1,
,BMW,23423,1,
,OPEL,54322,1,`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);