use strict;
my $str = 'foo
aaa bbb';
my $regex = qr/^(?:(?!foo).)*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";