import re
regex = re.compile(r"^(?:(?!foo).)*$", flags=re.MULTILINE)
test_str = ("foo\n"
"aaa bbb")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)