#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^section1):([a-zA-Z0-9\- ]+?)(?:-xx|\s*$)"
Local $sString = "section1:ypsilon " & @CRLF & _
"section1:ypsilon zeta " & @CRLF & _
"section1:ypsilon-zeta" & @CRLF & _
"section1:ypsilon-xx " & @CRLF & _
"section1:ypsilon zeta-xx" & @CRLF & _
"section1:ypsilon-zeta-xx" & @CRLF & _
"section2:ypsilon : section 2 does not match" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")