import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^section1):([a-zA-Z0-9\\- ]+?)(?:-xx|\\s*$)";
final String string = "section1:ypsilon \n"
+ "section1:ypsilon zeta \n"
+ "section1:ypsilon-zeta\n"
+ "section1:ypsilon-xx \n"
+ "section1:ypsilon zeta-xx\n"
+ "section1:ypsilon-zeta-xx\n"
+ "section2:ypsilon : section 2 does not match\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}