$re = '/(?<=^section1):([a-zA-Z0-9\- ]+?)(?:-xx|\s*$)/m';
$str = 'section1:ypsilon
section1:ypsilon zeta
section1:ypsilon-zeta
section1:ypsilon-xx
section1:ypsilon zeta-xx
section1:ypsilon-zeta-xx
section2:ypsilon : section 2 does not match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);